Cheat Engine Forum Index Cheat Engine
The Official Site of Cheat Engine
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Cheat Engine caused? PERMANENTLY? dead XboxOne controller(s)

Post new topic   Reply to topic    Cheat Engine Forum Index -> General Discussions
View previous topic :: View next topic  
Author Message
How do I cheat?
Reputation: 0

Joined: 10 Jul 2017
Posts: 2
Location: USA-FL

PostPosted: Mon Jul 10, 2017 8:17 pm    Post subject: Cheat Engine caused? PERMANENTLY? dead XboxOne controller(s) Reply with quote

Alright...I'm going to give as much detail as possible.

I'm playing Witcher 3, getting caca'd's on hard & i suck so, I throw open Cheat Engine & load a table. BTW I'm right at the first fight in the game, first time playing. I edit some things & when I get to the Carry Weight value & try to check the box, my fan spins quite loudly & for about 5-10 sec or so. I didn't notice that immediately, so I tried that about 5 times. I was like "EW...better stop that"

So I Alt+Tab back to Witcher 3, & my XBone controller (Wireless one with USB wired/charging) doesn't work....hmm. I looked for a solution online. It was suggested I remove the driver & reinstall it. "Microsoft Xbox One Controller" wasn't showing up, but a specific Unknown Driver was appearing & disappearing, so I deleted that one. What happens?.....ALL USB devices stop working, keyboard n mouse dead.

Some swearing....some verbal threats directed at my controller....a bunch of restarts. The keyboard & mouse worked on BIOS but as soon as Windows would load, nothing, even safe mode.
SO, I did a "Reset". That's Windows 8.1, I keep my files, but it resets the computer. This got my keyboard & mouse back. When plugging in the XBone controller, I got a "USB device malfunctioned" message.
I got my dusty XBone out of the closet to test the controller, it wouldn't work. IT LIT UP, as on the PC, but it wouldn't recognize inputs.

ONTU BESTu BUYu. I buy a new controller & cable, come home, into the PC it goes, I hear the "connected" noise & 5 seconds later, the disconnected noise. Pubes. I plugged it into the XBone, updated the new controller, & tried it again. Still nothing. Same connected sound, followed by the disconnected sound.
I also tried getting the drivers through windows automatically, & the computer said all the drivers were up to date. When I search dainternitz & Microsoft's site, I can't find any drivers to DL, & Microsoft says it'll DL automatically when I plug it in. Frrrrp.

Here's the sickening inconsistency that makes me call upon every swear I learned from youswear dot com. AFTER I updated the new controller I bought, I plugged the OLD one into the XBox One for funsies, N U GUESSED IT, the old controller works on the XBox One. AGRAGRGARGAGRG!

I've returned the new controller today, & I just got done doing a complete factory reset & new Windows install, & the controller still gives me the USB device malfunctioned error.
I suppose I could play GTAV offline or Halo Collection on my XBone, but I'd rather stare at the 118 games I own on STEAM & weep under the moonlight.

My hypothesis is, that I was at a point in the game that had no carry weight yet (hadn't checked), & when I checked the 10,000 option in the cheat table.....well....something something technologically over my head....something something cry into bowl of cereal.

plz halp?
Back to top
View user's profile Send private message
Dark Byte
Site Admin
Reputation: 354

Joined: 09 May 2003
Posts: 20671
Location: The netherlands

PostPosted: Tue Jul 11, 2017 1:37 am    Post subject: Reply with quote

sometimes when two applications use the controller at the same time it stops working. closing one of them or rebooting usually fixes it.

my guess where things went wrong is when you uninstalled the drivers for it. something may have gone wrong with the uninstall (perhaps it was still in use) causing it to not delete all files, breaking reinstall (usb drivers can be finicky like that)
and if the issue is caused by a file that shouldn't be there anymore then a reset of the system files wouldn't work.

only thing i can recommend is make a full backup of your system, and reinstall windows from scratch, deleting the old hard disk partition first

(and it's also possible the usb port you used has died. tried it in the one your mouse is in ?)

Do not ask me about online cheats. I don't know any and wont help finding them.
Back to top
View user's profile Send private message MSN Messenger
How do I cheat?
Reputation: 0

Joined: 10 Jul 2017
Posts: 2
Location: USA-FL

PostPosted: Wed Jul 12, 2017 5:43 pm    Post subject: Reply with quote

Hmm, I did a full reinstall after backing everything up, but it was through the options in Windows. I didn't delete any partition unless that was automatically part of their process.

As for the usb ports, all my devices worked again after the Refresh, which were a webcam, AudioBoxUSB, keyboard & mouse. External hard drives work in every USB port so it didn't fry them. I also tried plugging the controller into the back USB ports which I forgot to mention. It's just any Xbone controller, my PC refuses to take them anymore.

This is tragically confusing & intriguing...
Thank you for your help
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Cheat Engine Forum Index -> General Discussions All times are GMT - 6 Hours
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group

CE Wiki   IRC (#CEF)   Twitter
Third party websites